Debian セキュリティ勧告

DSA-1389-2 zoph -- 入力のサニタイズ漏れ

報告日時:
2007-10-18
影響を受けるパッケージ:
zoph
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 435711.
Mitre の CVE 辞書: CVE-2007-3905.
詳細:

ウェブベースの写真管理システム zoph が入力を適切にサニタイズしていないた め、SQL インジェクション攻撃を許すことが発見されました。

旧安定版 (oldstable) ディストリビューション (sarge) では、この問題はバー ジョン 0.3.3-12sarge3 で修正されています。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 0.6-2.1etch1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 0.7.0.2-1 で修正されています。

直ぐに zoph パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge3.dsc
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge3.diff.gz
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge3_all.deb

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6-2.1etch1.dsc
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6-2.1etch1.diff.gz
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.6-2.1etch1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。