Bulletin d'alerte Debian

DSA-1393-1 xfce4-terminal -- Exécution peu sûre

Date du rapport :
23 octobre 2007
Paquets concernés :
xfce4-terminal
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 437454.
Dans le dictionnaire CVE du Mitre : CVE-2007-3770.
Plus de précisions :

On a découvert que xfce-terminal, un émulateur de terminal pour l'environnement xfce, ne protégeait pas correctement les arguments passés aux processus engendrés par Open Link. Cela permet à des liens malveillants d'exécuter des commandes arbitraires sur le système local.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 0.2.5.6rc1-2etch1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.2.6-3.

Nous vous recommandons de mettre à jour votre paquet xfce4-terminal.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1.dsc
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1.diff.gz
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xfce4-terminal/xfce4-terminal_0.2.5.6rc1-2etch1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.