Рекомендация Debian по безопасности

DSA-1403-1 phpmyadmin -- отсутствие очистки входных данных

Дата сообщения:
08.11.2007
Затронутые пакеты:
phpmyadmin
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2007-5589, CVE-2007-5386.
Более подробная информация:

Омер Сингер из DigiTrust Group обнаружил несколько уязвимостей в phpMyAdmin, приложении для администрирования MySQL через WWW. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2007-5589

    phpMyAdmin позволяет удалённому злоумышленнику вводить произвольный веб-сценарий или код HTML в контекст сессии вошедшего пользователя (межсайтовый скриптинг).

  • CVE-2007-5386

    phpMyAdmin, при обращении браузера, который не кодирует с помощью URL запросы, позволяет удалённым злоумышленникам вводить произвольный веб-сценарий или код HTML с помощью строки запроса.

В предыдущем стабильном выпуске (sarge) эта проблема была исправлена в версии 4:2.6.2-3sarge6.

В стабильном выпуске (etch) эта проблема была исправлена в версии 4:2.9.1.1-6.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 4:2.11.1.2-1.

Рекомендуется обновить пакет phpmyadmin.

Исправлено в:

Debian GNU/Linux 3.1 (sarge)

Исходный код:
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge6.dsc
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge6.diff.gz
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge6_all.deb

Debian GNU/Linux 4.0 (etch)

Исходный код:
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-6.dsc
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-6.diff.gz
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-6_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.