Debian Security Advisory

DSA-1404-1 gallery2 -- programming error

Date Reported:
08 Nov 2007
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2007-4650.
More information:

Nicklous Roberts discovered that the Reupload module of Gallery 2, a web based photo management application, allowed unauthorized users to edit Gallery's data file.

The oldstable distribution (sarge) does not contain a gallery2 package. The previous gallery package is not affected by this vulnerability.

For the stable distribution (etch) this problem has been fixed in version 2.1.2-2.0.etch.1.

For the unstable distribution (sid) this problem has been fixed in version 2.2.3-1.

We recommend that you upgrade your gallery2 package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.