Debian-Sicherheitsankündigung

DSA-1418-1 cacti -- Fehlende Eingabebereinigung

Datum des Berichts:
02. Dez 2007
Betroffene Pakete:
cacti
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 452085.
In Mitres CVE-Verzeichnis: CVE-2007-6035.
Weitere Informationen:

Es wurde entdeckt, dass Cacti, ein Werkzeug zum Verfolgen von Systemen und Netzwerken, eine unzureichende Eingabebereinigung durchführt, was eine SQL-Einschleusung ermöglicht.

Für die alte Stable-Distribution (Sarge) wurde dieses Problem in Version 0.8.6c-7sarge5 behoben.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 0.8.6i-3.2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.8.7a-1 behoben.

Wir empfehlen Ihnen, Ihr cacti-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (oldstable)

Quellcode:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge5.diff.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge5.dsc
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge5_all.deb

Debian GNU/Linux 4.0 (stable)

Quellcode:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.2.dsc
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.2.diff.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.