Bulletin d'alerte Debian

DSA-1418-1 cacti -- Vérifications d'entrées manquantes

Date du rapport :
2 décembre 2007
Paquets concernés :
cacti
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 452085.
Dans le dictionnaire CVE du Mitre : CVE-2007-6035.
Plus de précisions :

On a découvert que Cacti, un outil pour surveiller les systèmes et les réseaux, de réalisait pas de vérification suffisante des entrées. Cela permet l'injection de code SQL.

Pour l'ancienne distribution stable (Sarge), ce problème a été corrigé dans la version 0.8.6c-7sarge5.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 0.8.6i-3.2.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.8.7a-1.

Nous vous recommandons de mettre à jour vos paquets cacti.

Corrigé dans :

Debian GNU/Linux 3.1 (oldstable)

Source :
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge5.diff.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge5.dsc
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge5_all.deb

Debian GNU/Linux 4.0 (stable)

Source :
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.2.dsc
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.2.diff.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.