Debian Security Advisory

DSA-1424-1 iceweasel -- several vulnerabilities

Date Reported:
08 Dec 2007
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2007-5947, CVE-2007-5959, CVE-2007-5960.
More information:

Several remote vulnerabilities have been discovered in the Iceweasel web browser, an unbranded version of the Firefox browser. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2007-5947

    Jesse Ruderman and Petko D. Petkov discovered that the URI handler for JAR archives allows cross-site scripting.

  • CVE-2007-5959

    Several crashes in the layout engine were discovered, which might allow the execution of arbitrary code.

  • CVE-2007-5960

    Gregory Fleischer discovered a race condition in the handling of the window.location property, which might lead to cross-site request forgery.

The Mozilla products in the oldstable distribution (sarge) are no longer supported with security updates.

For the stable distribution (etch) these problems have been fixed in version

For the unstable distribution (sid) these problems have been fixed in version

We recommend that you upgrade your iceweasel packages.

Fixed in:

Debian GNU/Linux 4.0 (stable)

Architecture-independent component:
HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.