Bulletin d'alerte Debian

DSA-1439-1 typo3-src -- Vérifications d'entrées manquantes

Date du rapport :
28 décembre 2007
Paquets concernés :
typo3-src
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 457446.
Dans le dictionnaire CVE du Mitre : CVE-2007-6381.
Plus de précisions :

Henning Pingel a découvert que TYPO3, un environnement de gestion de contenu sur la Toile, ne réalisait pas de vérification suffisante des entrées. Cela le rend vulnérable à des injections de code SQL par des utilisateurs connectés au dorsal.

L'ancienne distribution stable (Sarge) ne contient pas de paquet typo3-src.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 4.0.2+debian-4.

Pour la distribution instable (Sid) et la distribution de test (Lenny), ce problème a été corrigé dans la version 4.1.5-1.

Nous vous recommandons de mettre à jour vos paquets typo3-src.

Corrigé dans :

Debian GNU/Linux 4.0 (stable)

Source :
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src_4.0.2+debian-4.diff.gz
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src_4.0.2+debian.orig.tar.gz
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src_4.0.2+debian-4.dsc
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/t/typo3-src/typo3_4.0.2+debian-4_all.deb
http://security.debian.org/pool/updates/main/t/typo3-src/typo3-src-4.0_4.0.2+debian-4_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.