Bulletin d'alerte Debian

DSA-1440-1 inotify-tools -- Débordement de mémoire tampon

Date du rapport :
28 décembre 2007
Paquets concernés :
inotify-tools
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 443913.
Dans le dictionnaire CVE du Mitre : CVE-2007-5037.
Plus de précisions :

On a découvert qu'un débordement de mémoire tampon dans le traitement des noms de fichiers d'inotify-tools, une interface en ligne de commande à inotify, pouvait conduire à l'exécution de code arbitraire. Cela n'affecte que la bibliothèque interne et aucun des outils frontaux fournis par Debian.

L'ancienne distribution stable (Sarge) ne contient pas de paquet inotify-tools.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 3.3-2.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 3.11-1.

Nous vous recommandons de mettre à jour votre paquet inotify-tools.

Corrigé dans :

Debian GNU/Linux 4.0 (stable)

Source :
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2.dsc
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3.orig.tar.gz
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/i/inotify-tools/inotify-tools_3.3-2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.