Debian セキュリティ勧告

DSA-1443-1 tcpreen -- バッファオーバフロー

報告日時:
2008-01-03
影響を受けるパッケージ:
tcpreen
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2007-6562.
詳細:

TCP コネクションをモニタするツール tcpreen に複数のバッファオーバフロー があり、サービス拒否攻撃が可能であることが発見されました。

旧安定版 (sarge) には tcpreen パッケージは収録されていません。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 1.4.3-0.1etch1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 1.4.3-0.3 で修正されています。

直ぐに tcpreen パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (stable)

ソース:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1.dsc
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3.orig.tar.gz
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/t/tcpreen/tcpreen_1.4.3-0.1etch1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。