Рекомендация Debian по безопасности

DSA-1465-2 apt-listchanges -- ошибка программирования

Дата сообщения:
17.01.2008
Затронутые пакеты:
apt-listchanges
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2008-0302.
Более подробная информация:

Филипе Сетэлер обнаружил, что apt-listchanges, инструмент уведомления об изменении истории пакета, использует небезопасные пути при импортировании Python-библиотек. Это может позволить выполнить произвольные команды командной оболочки в случае, если суперпользователь выполняет команду в каталоге, открытый для записи другим пользователя.

В предыдущем стабильном выпуске (sarge) эта проблема отсутствует.

В стабильном выпуске (etch) эта проблема была исправлена в версии 2.72.5etch1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 2.82.

Рекомендуется обновить пакет apt-listchanges.

Исправлено в:

Debian GNU/Linux 4.0 (etch)

Исходный код:
http://security.debian.org/pool/updates/main/a/apt-listchanges/apt-listchanges_2.72.5etch2.tar.gz
http://security.debian.org/pool/updates/main/a/apt-listchanges/apt-listchanges_2.72.5etch2.dsc
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/a/apt-listchanges/apt-listchanges_2.72.5etch2_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.