Säkerhetsbulletin från Debian

DSA-1465-2 apt-listchanges -- programmeringsfel

Rapporterat den:
2008-01-17
Berörda paket:
apt-listchanges
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2008-0302.
Ytterligare information:

Felipe Sateler upptäckte att apt-listchanges, ett verktyg för att få information om paketändringshistorik, använde osäkra sökvägar vid import av sina pythonbibliotek. Detta kunde göra det möjligt för exekvering av godtyckliga skalkommandon om rootanvändaren exekverade kommandot i en katalog där andra lokala användare kunde skriva.

För den gamla stabila utgåvan (Sarge) finns inte detta problem.

För den stabila utgåvan (Etch) har detta problem rättats i version 2.72.5etch1.

För den instabila utgåvan (Sid) har detta problem rättats i version 2.82.

Vi rekommenderar att ni uppgraderar ert apt-listchanges-paket.

Rättat i:

Debian GNU/Linux 4.0 (etch)

Källkod:
http://security.debian.org/pool/updates/main/a/apt-listchanges/apt-listchanges_2.72.5etch2.tar.gz
http://security.debian.org/pool/updates/main/a/apt-listchanges/apt-listchanges_2.72.5etch2.dsc
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/a/apt-listchanges/apt-listchanges_2.72.5etch2_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.