Debians sikkerhedsbulletin

DSA-1467-1 mantis -- flere sårbarheder

Rapporteret den:
19. jan 2008
Berørte pakker:
mantis
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 402802, Fejl 458377.
I Mitres CVE-ordbog: CVE-2006-6574, CVE-2007-6611.
Yderligere oplysninger:

Flere fjernudnytbare sårbarheder er opdaget i Mantis, et webbaseret fejlsporingssystem. Projektet Common Vulnerabilities and Exposures har fundet frem til følgende problemer:

  • CVE-2006-6574

    Skræddersyede felter blev ikke beskyttet tilstrækkeligt af pr. punkt-adgangskontrol, hvilket muliggjorde offentliggørelse af følsomme data.

  • CVE-2007-6611

    Flere problemer med udførelse af skripter på tværs af servere, gjorde det muligt for fjernangribere at indsætte ondsindet HTML eller webskript i Mantis-websider.

I den gamle stabile distribution (sarge), er disse problemer rettet i version 0.19.2-5sarge5.

Den stabile distribution (etch) er ikke påvirket af disse problemer.

I den ustabile distribution (sid), er disse problemer rettet i version 1.0.8-4.

Vi anbefaler at du opgraderer din mantis-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge5.dsc
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2.orig.tar.gz
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge5.diff.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge5_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.