Säkerhetsbulletin från Debian

DSA-1467-1 mantis -- flera sårbarheter

Rapporterat den:
2008-01-19
Berörda paket:
mantis
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 402802, Fel 458377.
I Mitres CVE-förteckning: CVE-2006-6574, CVE-2007-6611.
Ytterligare information:

Flera utifrån nåbara sårbarheter har upptäckts i Mantis, ett webbaserat felrapporteringssystem. Projektet Common Vulnerabilities and Exposures identifierar följande problem:

  • CVE-2006-6574

    Egna fält skyddades inte korrekt av åtkomstbegränsningar per post, vilket gjorde det möjligt för känslig data att publiceras.

  • CVE-2007-6611

    Flera serveröverskridande skriptproblem gjorde det möjligt för en angripare utifrån att sätta in skadlig HTML-kod eller webbskript i Mantiswebbsidor.

För den gamla stabila utgåvan (Sarge) har dessa problem rättats i version 0.19.2-5sarge5.

Den stabila utgåvan (Etch) påverkas inte by av dessa problem.

För den instabila utgåvan (Sid) har dessa problem rättats i version 1.0.8-4.

Vi rekommenderar att ni uppgraderar ert mantis-paket.

Rättat i:

Debian GNU/Linux 3.1 (sarge)

Källkod:
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge5.dsc
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2.orig.tar.gz
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge5.diff.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge5_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.