Debians sikkerhedsbulletin

DSA-1473-1 scponly -- designfejl

Rapporteret den:
21. jan 2008
Berørte pakker:
scponly
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 437148.
I Mitres CVE-ordbog: CVE-2007-6350, CVE-2007-6415.
Yderligere oplysninger:

Joachim Breitner opdagede at Subversion-understøttelsen i scponly generelt er usikker, hvilket gjorde det muligt for udføre vilkårlige kommandoer. Yderligere undersøgelser viste at rsync- og Unison-understøttelsen var ramt af lignende problemer. Disse problemer har fået tildelt CVE-2007-6350.

Desuden opdagede man at det var muligt, at kalde scp med visse valgmuligheder, der kunne føre til udførelse af vilkårlige kommandoer (CVE-2007-6415).

Denne opdatering fjerner understøttelse af Subversion, rsync og Unison fra pakken scponly, og forhindrer scp i at blive kaldt med farlige valgmuligheder.

I den gamle stabile distribution (sarge), er disse problemer rettet i version 4.0-1sarge2.

I den stabile distribution (etch), er disse problemer rettet i version 4.6-1etch1.

Den ustabile distribution (sid) vil snart blive rettet.

Vi anbefaler at du opgraderer din scponly-pakke.

Rettet i:

Debian GNU/Linux 3.1 (oldstable)

Kildekode:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2.diff.gz
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2.dsc
Alpha:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_m68k.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_sparc.deb

Debian GNU/Linux 4.0 (stable)

Kildekode:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1.diff.gz
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1.dsc
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.