Debian-Sicherheitsankündigung

DSA-1473-1 scponly -- Design-Schwäche

Datum des Berichts:
21. Jan 2008
Betroffene Pakete:
scponly
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 437148.
In Mitres CVE-Verzeichnis: CVE-2007-6350, CVE-2007-6415.
Weitere Informationen:

Joachim Breitner entdeckte, dass die Subversion-Unterstützung in scponly sehr unsicher ist, was die Ausführung beliebiger Kommandos ermöglicht. Eine weitere Untersuchung zeigte, dass rsync- und Unison-Unterstützung von ähnlichen Problemen betroffen sind. Diesen Problemen wurde CVE-2007-6350 zugewiesen.

Zusätzlich wurde entdeckt, dass es möglich war, scp mit mehreren Optionen zu starten, die zur Ausführung beliebiger Kommandos führen können (CVE-2007-6415).

Diese Aktualisierung entfernt Subversion-, rsync- und Unison-Unterstützung vom Paket scponly und verhindert, dass scp mit den gefährlichen Optionen aufgerufen wird.

Für die alte Stable-Distribution (Sarge) wurden diese Probleme in Version 4.0-1sarge2 behoben.

Für die Stable-Distribution (Etch) wurden diese Probleme in Version 4.6-1etch1 behoben.

Für die Unstable-Distribution (Sid) werden diese Probleme bald behoben sein.

Wir empfehlen Ihnen, Ihr scponly-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (oldstable)

Quellcode:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2.diff.gz
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2.dsc
Alpha:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_m68k.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge2_sparc.deb

Debian GNU/Linux 4.0 (stable)

Quellcode:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1.diff.gz
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1.dsc
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.6-1etch1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.