Bulletin d'alerte Debian

DSA-1475-1 gforge -- Vérifications d'entrées manquantes

Date du rapport :
26 janvier 2008
Paquets concernés :
gforge
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2007-0176.
Plus de précisions :

José Ramón Palanco a découvert qu'une vulnérabilité de scripts intersites dans GForge, un outil de développement collaboratif, permettait à un attaquant distant d'injecter un script arbitraire ou du HTML dans le contexte d'une session d'utilisateur connecté.

L'ancienne distribution stable (Sarge) n'est pas affectée.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 4.5.14-22etch5.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 4.6.99+svn6347-1.

Nous vous recommandons de mettre à jour votre paquet gforge.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14.orig.tar.gz
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14-22etch5.dsc
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14-22etch5.diff.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-postfix_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-common_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-exim_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-exim4_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-web-apache_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-courier_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-db-postgresql_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-lists-mailman_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-ftp-proftpd_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-dns-bind9_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-shell-ldap_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-shell-postgresql_4.5.14-22etch5_all.deb
http://security.debian.org/pool/updates/main/g/gforge/gforge-ldap-openldap_4.5.14-22etch5_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.