Debian セキュリティ勧告

DSA-1477-1 yarssr -- 入力のサニタイズ漏れ

報告日時:
2008-01-27
影響を受けるパッケージ:
yarssr
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2007-5837.
詳細:

Duncan Gilmore さんにより、RSS 収集およびリーダ yarssr が入力のサニタイ ズを十分に行っていないため、不正なフィードを読んだ場合に任意のシェルコマ ンドが実行可能であることが発見されました。

アーカイブ管理スクリプトの技術的制限のため、旧安定版 (Sarge) 向けの修正 は数日延期されます。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 0.2.2-1etch1 で修正されています。

直ぐに yarssr パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (stable)

ソース:
http://security.debian.org/pool/updates/main/y/yarssr/yarssr_0.2.2-1etch1.diff.gz
http://security.debian.org/pool/updates/main/y/yarssr/yarssr_0.2.2.orig.tar.gz
http://security.debian.org/pool/updates/main/y/yarssr/yarssr_0.2.2-1etch1.dsc
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/y/yarssr/yarssr_0.2.2-1etch1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。