Debian セキュリティ勧告

DSA-1482-1 squid -- プログラムミス

報告日時:
2008-02-05
影響を受けるパッケージ:
squid
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2007-6239.
詳細:

Squid WWW プロキシキャッシュに不正な形式のキャッシュ更新応答を返すことに よりシステムメモリを消費させ、サービス拒否攻撃が可能であることが発見され ました。

旧安定版 (sarge) 向けは、現在アーカイブ管理スクリプトのバグのため buildd セキュリティネットワークで処理できません。i386 向けの更新のみ一時的に https://people.debian.org/~jmm/squid/ で提供しています。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 2.6.5-6etch1 で修正されています。

直ぐに squid パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (stable)

ソース:
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1.dsc
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5.orig.tar.gz
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/s/squid/squid-common_2.6.5-6etch1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_alpha.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_alpha.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_amd64.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_amd64.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_arm.deb
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_arm.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_hppa.deb
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_hppa.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_i386.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_i386.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_ia64.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_ia64.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_mips.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_mips.deb
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_mipsel.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_mipsel.deb
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_powerpc.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_powerpc.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_s390.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_s390.deb
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/squid/squid_2.6.5-6etch1_sparc.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.6.5-6etch1_sparc.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.6.5-6etch1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。