Säkerhetsbulletin från Debian

DSA-1486-1 gnatsweb -- serveröverskridande skriptfel

Rapporterat den:
2008-02-04
Berörda paket:
gnatsweb
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 427156.
I Mitres CVE-förteckning: CVE-2007-2808.
Ytterligare information:

r0t upptäckte att gnatsweb, ett webbgränssnitt mot GNU GNATS, inte korrekt städade databasparametern i huvud-CGI-skriptet. Detta kunde göra det möjligt att injicera godtycklig HTML- eller JavaScriptkod.

För den stabila utgåvan (Etch) har detta problem rättats i version 4.00-1etch1.

Vi rekommenderar att ni uppgraderar ert gnatsweb-paket.

Rättat i:

Debian GNU/Linux 4.0 (etch)

Källkod:
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00-1etch1.dsc
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00.orig.tar.gz
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00-1etch1.diff.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00-1etch1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.