Debian Security Advisory

DSA-1488-1 phpbb2 -- several vulnerabilities

Date Reported:
09 Feb 2008
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 388120, Bug 405980, Bug 463589.
In Mitre's CVE dictionary: CVE-2006-4758, CVE-2006-6839, CVE-2006-6840, CVE-2006-6508, CVE-2006-6841, CVE-2008-0471.
More information:

Several remote vulnerabilities have been discovered in phpBB, a web based bulletin board. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2008-0471

    Private messaging allowed cross site request forgery, making it possible to delete all private messages of a user by sending them to a crafted web page.

  • CVE-2006-6841 / CVE-2006-6508

    Cross site request forgery enabled an attacker to perform various actions on behalf of a logged in user. (Applies to sarge only.)

  • CVE-2006-6840

    A negative start parameter could allow an attacker to create invalid output. (Applies to sarge only.)

  • CVE-2006-6839

    Redirection targets were not fully checked, leaving room for unauthorised external redirections via a phpBB forum. (Applies to sarge only.)

  • CVE-2006-4758

    An authenticated forum administrator may upload files of any type by using specially crafted filenames. (Applies to sarge only.)

For the old stable distribution (sarge), these problems have been fixed in version 2.0.13+1-6sarge4.

For the stable distribution (etch), these problems have been fixed in version 2.0.21-7.

For the unstable distribution (sid) these problems have been fixed in version 2.0.22-3.

We recommend that you upgrade your phpbb2 package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.