Debian-Sicherheitsankündigung

DSA-1488-1 phpbb2 -- Mehrere Verwundbarkeiten

Datum des Berichts:
09. Feb 2008
Betroffene Pakete:
phpbb2
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 388120, Fehler 405980, Fehler 463589.
In Mitres CVE-Verzeichnis: CVE-2006-4758, CVE-2006-6839, CVE-2006-6840, CVE-2006-6508, CVE-2006-6841, CVE-2008-0471.
Weitere Informationen:

Mehrere entfernt-ausnutzbare Verwundbarkeiten wurden in phpBB, einem Web-basierten Forum (bulletin board), gefunden. Das Common Vulnerabilities and Exposures project identifiziert die folgenden Probleme:

  • CVE-2008-0471

    Privater Nachrichtenversand erlaubt Site-übergreifende Anfragefälschung, die es ermöglicht, alle privaten Nachrichten eines Benutzer zu löschen, indem die Benutzer auf eine speziell-präparierte Webseite geschickt werden.

  • CVE-2006-6841 / CVE-2006-6508

    Site-übergreifende Anfragefälschung ermöglichte es einem Angreifer, verschiedene Aktionen stellvertretend für einen angemeldeten Benutzer durchzuführen (betrifft nur Sarge).

  • CVE-2006-6840

    Ein negativer Start-Parameter könnte es Angreifern erlauben, ungültige Ausgaben zu erzeugen (betrifft nur Sarge).

  • CVE-2006-6839

    Umleitungs-Ziele wurden nicht vollständig überprüft und ließen Raum für nicht-autorisierte externe Umleitungen über ein phpBB-Forum (betrifft nur Sarge).

  • CVE-2006-4758

    Ein authentifizierter Forum-Administrator könnte Dateien beliebigen Typs mittels speziell-erstellter Dateinamen hochladen (betrifft nur Sarge).

Für die alte stabile Distribution (Sarge) wurden diese Probleme in Version 2.0.13+1-6sarge4 behoben.

Für die stabile Distribution (Etch) wurden diese Probleme in Version 2.0.21-7 behoben.

Für die Unstable-Distribution (Sid) wurden diese Probleme in Version 2.0.22-3 behoben.

Wir empfehlen, dass Sie Ihr phpBB2-Paket aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13+1-6sarge4.diff.gz
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13+1.orig.tar.gz
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13+1-6sarge4.dsc
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2-conf-mysql_2.0.13-6sarge4_all.deb
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13-6sarge4_all.deb
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2-languages_2.0.13-6sarge4_all.deb

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.21-7.dsc
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.21.orig.tar.gz
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.21-7.diff.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2-languages_2.0.21-7_all.deb
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.21-7_all.deb
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2-conf-mysql_2.0.21-7_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.