Debian Security Advisory

DSA-1502-1 wordpress -- several vulnerabilities

Date Reported:
22 Feb 2008
Affected Packages:
wordpress
Vulnerable:
Yes
Security database references:
No other external database security references currently available.
More information:

Several remote vulnerabilities have been discovered in wordpress, a weblog manager. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2007-3238

    Cross-site scripting (XSS) vulnerability in functions.php in the default theme in WordPress allows remote authenticated administrators to inject arbitrary web script or HTML via the PATH_INFO (REQUEST_URI) to wp-admin/themes.php.

  • CVE-2007-2821

    SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

  • CVE-2008-0193

    Cross-site scripting (XSS) vulnerability in wp-db-backup.php in WordPress 2.0.11 and earlier allows remote attackers to inject arbitrary web script or HTML via the backup parameter in a wp-db-backup.php action to wp-admin/edit.php.

  • CVE-2008-0194

    Directory traversal vulnerability in wp-db-backup.php in WordPress 2.0.3 and earlier allows remote attackers to read arbitrary files, delete arbitrary files, and cause a denial of service via a .. (dot dot) in the backup parameter in a wp-db-backup.php action to wp-admin/edit.php.

Wordpress is not present in the oldstable distribution (sarge).

For the stable distribution (etch), these problems have been fixed in version 2.0.10-1etch1.

We recommend that you upgrade your wordpress package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Source:
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch1.diff.gz
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10.orig.tar.gz
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch1.dsc
Architecture-independent component:
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch1_all.deb

MD5 checksums of the listed files are available in the original advisory.