Debian-Sicherheitsankündigung

DSA-1507-1 turba2 -- Programmierfehler

Datum des Berichts:
24. Feb 2008
Betroffene Pakete:
turba2
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 464058.
In Mitres CVE-Verzeichnis: CVE-2008-0807.
Weitere Informationen:

Peter Paul Elfferich entdeckte, dass turba2, eine Kontaktverwaltungskomponente für das Horde-Framework, Zugriffsrechte nicht korrekt überprüft, bevor Benutzern das Bearbeiten von Adressen erlaubt wird. Dies kann dazu führen, dass falsche Benutzer private Adressdaten ändern.

Für die alte Stable-Distribution (Sarge) wurde dieses Problem in Version 2.0.2-1sarge1 behoben.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 2.1.3-1etch1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 2.1.7-1 behoben.

Wir empfehlen Ihnen, Ihr turba2-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2-1sarge1.dsc
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2-1sarge1_all.deb

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3-1etch1.diff.gz
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3.orig.tar.gz
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3-1etch1.dsc
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3-1etch1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.