Bulletin d'alerte Debian

DSA-1507-1 turba2 -- Erreur de programmation

Date du rapport :
24 février 2008
Paquets concernés :
turba2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 464058.
Dans le dictionnaire CVE du Mitre : CVE-2008-0807.
Plus de précisions :

Peter Paul Elfferich a découvert que turba2, un composent de gestion des contacts pour l'environnement horde, ne vérifiait pas correctement les droits d'accès avant de permettre aux utilisateurs d'éditer des adresses. Cela peut permettre à des utilisateurs valides de modifier des enregistrements privés.

Pour l'ancienne distribution stable (Sarge), ce problème a été corrigé dans la version 2.0.2-1sarge1.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 2.1.3-1etch1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 2.1.7-1.

Nous vous recommandons de mettre à jour votre paquet turba2.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2-1sarge1.dsc
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.0.2-1sarge1_all.deb

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3-1etch1.diff.gz
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3.orig.tar.gz
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3-1etch1.dsc
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/t/turba2/turba2_2.1.3-1etch1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.