Debians sikkerhedsbulletin

DSA-1523-1 ikiwiki -- udførelse af skripter på tværs af websteder

Rapporteret den:
17. mar 2008
Berørte pakker:
ikiwiki
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2008-0808, CVE-2008-0809.
Yderligere oplysninger:

Josh Triplett opdagede at ikiwiki ikke blokerede for JavaScript i URL'er, hvilket førte til sårbarheder i forbindelse med udførelse af skripter på tværs af websteder (CVE-2008-0808, CVE-2008-0809).

Den gamle stabile distribution (sarge) indeholder ikke en ikiwiki-pakke.

I den stabile distribution (etch), er dette problem rettet i version 1.33.4.

I den ustabile distribution (sid), er dette problem rettet i version 2.31.1.

Vi anbefaler at du opgraderer din ikiwiki-pakke.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.dsc
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.