Debian-Sicherheitsankündigung

DSA-1523-1 ikiwiki -- Site-übergreifendes Skripting

Datum des Berichts:
17. Mär 2008
Betroffene Pakete:
ikiwiki
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2008-0808, CVE-2008-0809.
Weitere Informationen:

Josh Triplett entdeckte, dass ikiwiki Javascript in URLs nicht blockiert, was zu Site-übergreifenden Skripting-Verwundbarkeiten führt (CVE-2008-0808, CVE-2008-0809).

Die alte Stable-Distribution (Sarge) enthält das Paket nicht.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 1.33.4 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 2.31.1 behoben.

Wir empfehlen Ihnen, Ihr ikiwiki-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.dsc
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.