Bulletin d'alerte Debian

DSA-1523-1 ikiwiki -- Script intersite

Date du rapport :
17 mars 2008
Paquets concernés :
ikiwiki
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2008-0808, CVE-2008-0809.
Plus de précisions :

Josh Triplett a découvert qu'ikiwiki ne bloquait pas le JavaScript dans les URL. Cela conduit à des vulnérabilités de scripts intersites (CVE-2008-0808, CVE-2008-0809).

L'ancienne distribution stable (Sarge) ne contient pas de paquet ikiwiki.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 1.33.4.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 2.31.1.

Nous vous recommandons de mettre à jour votre paquet ikiwiki.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.dsc
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.