Debian セキュリティ勧告

DSA-1523-1 ikiwiki -- クロスサイトスクリプティングバグ

報告日時:
2008-03-17
影響を受けるパッケージ:
ikiwiki
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2008-0808, CVE-2008-0809.
詳細:

Josh Triplett さんにより、ikiwiki が URL 中の Javascript をブロックして いないため、クロスサイトスクリプティングバグがあることが発見されました (CVE-2008-0808, CVE-2008-0809)。

旧安定版には ikiwiki パッケージは収録されていません。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 1.33.4 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 2.31.1 で修正されています。

直ぐに ikiwiki パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.dsc
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_1.33.4_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。