Debian Security Advisory

DSA-1539-1 mapserver -- several vulnerabilities

Date Reported:
04 Apr 2008
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2007-4542, CVE-2007-4629.
More information:

Chris Schmidt and Daniel Morissette discovered two vulnerabilities in mapserver, a development environment for spatial and mapping applications. The Common Vulnerabilities and Exposures project identifies the following two problems:

  • CVE-2007-4542

    Lack of input sanitizing and output escaping in the CGI mapserver's template handling and error reporting routines leads to cross-site scripting vulnerabilities.

  • CVE-2007-4629

    Missing bounds checking in mapserver's template handling leads to a stack-based buffer overrun vulnerability, allowing a remote attacker to execute arbitrary code with the privileges of the CGI or httpd user.

For the stable distribution (etch), these problems have been fixed in version 4.10.0-5.1+etch2.

For the unstable distribution (sid), these problems have been fixed in version 4.10.3-1.

We recommend that you upgrade your mapserver (4.10.0-5.1+etch2) package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:
HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.