Debian-Sicherheitsankündigung

DSA-1548-1 xpdf -- Mehrere Verwundbarkeiten

Datum des Berichts:
17. Apr 2008
Betroffene Pakete:
xpdf
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2008-1693.
Weitere Informationen:

Kees Cook entdeckte eine Verwundbarkeit in xpdf, einer Sammlung von Werkzeugen für die Anzeige und Konvertierung von Dateien im Portable Document Format (PDF). Das Common Vulnerabilities and Exposures-Projekt identifiziert die folgenden Probleme:

  • CVE-2008-1693

    Es fehlt eine ausreichende Überprüfung und Typprüfung in Xpdf für eingebettete Schriften. Falls eine speziell bösartig erstellte PDF-Datei geöffnet wird, kann die Verwundbarkeit die Ausführung beliebigen Codes mit den Rechten des Benutzers, der xpdf gestartet hat, ermöglichen.

Für die Stable-Distribution (Etch) wurden diese Probleme in Version 3.01-9.1+etch4 behoben.

Für die Unstable-Distribution (Sid) sind diese Probleme in Version 3.02-1.2 behoben worden.

Wir empfehlen Ihnen, Ihr xpdf-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.01-9.1+etch4.dsc
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.01-9.1+etch4.diff.gz
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.01.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.01-9.1+etch4_all.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-common_3.01-9.1+etch4_all.deb
Alpha:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_alpha.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_amd64.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_arm.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_hppa.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_i386.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_ia64.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_mips.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_mips.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_powerpc.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.01-9.1+etch4_s390.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.01-9.1+etch4_s390.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.