Debian-Sicherheitsankündigung

DSA-1554-2 roundup -- Unzureichende Eingabebereinigung

Datum des Berichts:
22. Apr 2008
Betroffene Pakete:
roundup
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 472643.
In Mitres CVE-Verzeichnis: CVE-2008-1474.
Weitere Informationen:

Roundup, ein Fehlerverfolgungssystem, schützt HTML-Eingaben nicht korrekt, was es einem Angreifer ermöglicht, Klient-seitigen Code (typischerweise JavaScript) in ein Dokument einzuschleusen, das im Browser des Opfers betrachtet werden kann.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 1.2.1-5+etch2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 1.3.3-3.1 behoben.

Wir empfehlen Ihnen, Ihre roundup-Pakete zu aktualisieren.

Behoben in:

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.2.1-5+etch2.dsc
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.2.1.orig.tar.gz
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.2.1-5+etch2.diff.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.2.1-5+etch2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.