Debian-Sicherheitsankündigung

DSA-1560-1 kronolith2 -- unzureichende Eingabebereinigung

Datum des Berichts:
28. Apr 2008
Betroffene Pakete:
kronolith2
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 478121.
In Mitres CVE-Verzeichnis: CVE-2008-1974.
Weitere Informationen:

The-0utl4w entdeckte, dass Kronolith, eine Kalenderkomponente für das Horde-Rahmenwerk, URLs nicht korrekt bereinigte, was zu einer Site-übergreifenden Skriptingverwundbarkeit im add-event-Bildschirm führt.

Für die stabile Distribution (Etch) wurde dieses Problem in Version 2.1.4-1etch1 behoben.

Für die instabile Distribution (Sid) wurde dieses Problem in Version 2.1.8-1 behoben.

Wir empfehlen, dass Sie Ihr kronolith2-Paket aktualisieren.

Behoben in:

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4-1etch1.dsc
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4-1etch1.diff.gz
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4-1etch1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.