Säkerhetsbulletin från Debian

DSA-1560-1 kronolith2 -- otillräcklig städning av indata

Rapporterat den:
2008-04-28
Berörda paket:
kronolith2
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 478121.
I Mitres CVE-förteckning: CVE-2008-1974.
Ytterligare information:

”The-0utl4w” upptäckte att Kronolith, en kalenderkomponent för ramverket Horde, inte korrekt städar URL-indata, vilket kunde leda till en serveröverskridande skriptsårbarhet i skärmen för att lägga till evenemang.

För den stabila utgåvan (Etch) har detta problem rättats i version 2.1.4-1etch1.

För den instabila utgåvan (Sid) har detta problem rättats i version 2.1.8-1.

Vi rekommenderar att ni uppgraderar ert kronolith2-paket.

Rättat i:

Debian GNU/Linux 4.0 (etch)

Källkod:
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4-1etch1.dsc
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4-1etch1.diff.gz
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/k/kronolith2/kronolith2_2.1.4-1etch1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.