Debian-Sicherheitsankündigung

DSA-1569-2 cacti -- Unzureichende Eingabebereinigung

Datum des Berichts:
05. Mai 2008
Betroffene Pakete:
cacti
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2008-0783, CVE-2008-0785.
Weitere Informationen:

Es wurde entdeckt, dass Cacti, ein Frontend zum Beobachten von Systemen und Diensten, eine unzureichende Eingabebereinigung durchführt, was Site-übergreifendes Skripting und SQL-Einschleusung ermöglicht.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 0.8.6i-3.4 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.8.7b-1 behoben.

Wir empfehlen Ihnen, Ihr cacti-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.4.diff.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.4.dsc
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6i-3.4_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.