Debian Security Advisory

DSA-1577-1 gforge -- insecure temporary files

Date Reported:
14 May 2008
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2008-0167.
More information:

Stephen Gran and Mark Hymers discovered that some scripts run by GForge, a collaborative development tool, open files in write mode in a potentially insecure manner. This may be exploited to overwrite arbitrary files on the local system.

For the stable distribution (etch), this problem has been fixed in version 4.5.14-22etch8.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your gforge package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.