Debian Security Advisory

DSA-1592-1 linux-2.6 -- heap overflow

Date Reported:
09 Jun 2008
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2008-1673, CVE-2008-2358.
More information:

Two vulnerabilities have been discovered in the Linux kernel that may lead to a denial of service or arbitrary code execution. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2008-1673

    Wei Wang from McAfee reported a potential heap overflow in the ASN.1 decode code that is used by the SNMP NAT and CIFS subsystem. Exploitation of this issue may lead to arbitrary code execution. This issue is not believed to be exploitable with the pre-built kernel images provided by Debian, but it might be an issue for custom images built from the Debian-provided source package.

  • CVE-2008-2358

    Brandon Edwards of McAfee Avert labs discovered an issue in the DCCP subsystem. Due to missing feature length checks it is possible to cause an overflow that may result in remote arbitrary code execution.

For the stable distribution (etch) these problems have been fixed in version 2.6.18.dfsg.1-18etch6.

We recommend that you upgrade your linux-2.6, fai-kernels, and user-mode-linux packages.

Fixed in:

Debian GNU/Linux 4.0 (etch)
Architecture-independent component:
HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.