Debian Security Advisory

DSA-1593-1 tomcat5.5 -- missing input sanitising

Date Reported:
09 Jun 2008
Affected Packages:
tomcat5.5
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2008-1947.
More information:

It was discovered that the Host Manager web application performed insufficient input sanitising, which could lead to cross-site scripting.

For the stable distribution (etch), this problem has been fixed in version 5.5.20-2etch3.

For the unstable distribution (sid), this problem has been fixed in version 5.5.26-3.

We recommend that you upgrade your tomcat5.5 packages.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Source:
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20-2etch3.dsc
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20.orig.tar.gz
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20-2etch3.diff.gz
Architecture-independent component:
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5-admin_5.5.20-2etch3_all.deb
http://security.debian.org/pool/updates/main/t/tomcat5.5/libtomcat5.5-java_5.5.20-2etch3_all.deb
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5-webapps_5.5.20-2etch3_all.deb
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20-2etch3_all.deb

MD5 checksums of the listed files are available in the original advisory.