Bulletin d'alerte Debian

DSA-1593-1 tomcat5.5 -- Vérification d'entrée manquante

Date du rapport :
9 juin 2008
Paquets concernés :
tomcat5.5
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2008-1947.
Plus de précisions :

On a découvert que l'application de gestion d'hôtes ne réalisait pas de vérification suffisante des entrées. Cela peut permettre une attaque par script intersite.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 5.5.20-2etch3.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 5.5.26-3.

Nous vous recommandons de mettre à jour vos paquets tomcat5.5.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20-2etch3.dsc
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20.orig.tar.gz
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20-2etch3.diff.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5-admin_5.5.20-2etch3_all.deb
http://security.debian.org/pool/updates/main/t/tomcat5.5/libtomcat5.5-java_5.5.20-2etch3_all.deb
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5-webapps_5.5.20-2etch3_all.deb
http://security.debian.org/pool/updates/main/t/tomcat5.5/tomcat5.5_5.5.20-2etch3_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.