Debian Security Advisory

DSA-1596-1 typo3 -- several vulnerabilities

Date Reported:
12 Jun 2008
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 485814.
In Mitre's CVE dictionary: CVE-2008-2717, CVE-2008-2718.
More information:

Several remote vulnerabilities have been discovered in the TYPO3 content management framework.

Because of a not sufficiently secure default value of the TYPO3 configuration variable fileDenyPattern, authenticated backend users could upload files that allowed to execute arbitrary code as the webserver user.

User input processed by is not being properly filtered to prevent Cross Site Scripting (XSS) attacks, which is exposed when specific plugins are in use.

For the stable distribution (etch), these problems have been fixed in version 4.0.2+debian-5.

For the unstable distribution (sid), these problems have been fixed in version 4.1.7-1.

We recommend that you upgrade your typo3 package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.