Debian セキュリティ勧告

DSA-1598-1 libtk-img -- バッファオーバフロー

報告日時:
2008-06-19
影響を受けるパッケージ:
libtk-img
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2008-0553.
詳細:

クロスプラットフォーム画像ツールキット Tk の GIF 画像展開ツールにバッファ オーバフローが発見されました。この欠陥を攻撃することにより、サービス拒否 攻撃や任意のコードの実行が可能です。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 1:1.3-15etch2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 1:1.3-release-7 で修正されています。

直ぐに libtk-img パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2.dsc
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3.orig.tar.gz
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2.diff.gz
AMD64:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/libt/libtk-img/libtk-img_1.3-15etch2_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。