Debians sikkerhedsbulletin

DSA-1601-1 wordpress -- flere sårbarheder

Rapporteret den:
4. jul 2008
Berørte pakker:
wordpress
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 437085, Fejl 464170.
I Mitres CVE-ordbog: CVE-2007-1599, CVE-2008-0664.
Yderligere oplysninger:

Flere fjernudnytbare sårbarheder er opdaget i Wordpress, et weblogprogram. Projektet Common Vulnerabilities and Exposures har fundet frem til følgende problemer:

  • CVE-2007-1599

    WordPress gjorde det muligt for fjernangribere at omdirigere autentificerede brugere til andre websteder og potentielt få adgang til følsomme oplysninger.

  • CVE-2008-0664

    XML-RPC-implementeringen, når registrering er aktiveret, gjorde det muligt for fjernangribere at redigere indlæg fra andre blog-brugere.

I den stabile distribution (etch), er disse problemer rettet i version 2.0.10-1etch3.

I den ustabile distribution (sid), er disse problemer rettet i version 2.3.3-1.

Vi anbefaler at du opgraderer din wordpress-pakke.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10.orig.tar.gz
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch3.dsc
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch3.diff.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch3_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.