Debian Security Advisory

DSA-1614-1 iceweasel -- several vulnerabilities

Date Reported:
23 Jul 2008
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2008-2785, CVE-2008-2933.
More information:

Several remote vulnerabilities have been discovered in the Iceweasel web browser, an unbranded version of the Firefox browser. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2008-2785

    It was discovered that missing boundary checks on a reference counter for CSS objects can lead to the execution of arbitrary code.

  • CVE-2008-2933

    Billy Rios discovered that passing an URL containing a pipe symbol to Iceweasel can lead to Chrome privilege escalation.

For the stable distribution (etch), these problems have been fixed in version Updated packages for ia64, arm and mips are not yet available and will be released as soon as they have been built.

For the unstable distribution (sid), these problems have been fixed in xulrunner and iceweasel 3.0.1-1.

We recommend that you upgrade your iceweasel package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:
HP Precision:
Intel IA-32:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.