Debian セキュリティ勧告

DSA-1622-1 newsx -- バッファオーバフロー

報告日時:
2008-07-31
影響を受けるパッケージ:
newsx
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 492742.
Mitre の CVE 辞書: CVE-2008-3252.
詳細:

NNTP ニュース交換ユーティリティ newsx にバッファオーバフローがあり、ピリ オドで始まる膨大な行数のニュース記事によって、リモートの攻撃者が任意のコ ードを実行可能です。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 1.6-2etch1 で修正されています。

テスト版 (testing) および不安定版 (unstable) ディストリビューション (lenny および sid) では、この問題はバージョン 1.6-3 で修正されています。

直ぐに newsx パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1.dsc
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6.orig.tar.gz
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/n/newsx/newsx_1.6-2etch1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。