Debian セキュリティ勧告

DSA-1643-1 feta -- 安全でないファイルの扱い

報告日時:
2008-10-05
影響を受けるパッケージ:
feta
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 496397.
Mitre の CVE 辞書: CVE-2008-4440.
詳細:

Dmitry E. Oboukhov さんにより、feta の "to-upgrade" プラグインが安全でな い方法で一時ファイルを作成しているため、シンボリックリンク攻撃によりロー カルのサービス拒否攻撃が可能であることが発見されました。feta は APT, dpkg などの Debian パッケージツールにより単純なインターフェースを提供す るものです。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 1.4.15+etch1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 1.4.16+nmu1 で修正されています。

直ぐに feta パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/f/feta/feta_1.4.15+etch1.dsc
http://security.debian.org/pool/updates/main/f/feta/feta_1.4.15+etch1.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/f/feta/feta_1.4.15+etch1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。