Debians sikkerhedsbulletin

DSA-1657-1 qemu -- usikre midlertidige filer

Rapporteret den:
20. okt 2008
Berørte pakker:
qemu
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 496394.
I Mitres CVE-ordbog: CVE-2008-4553.
Yderligere oplysninger:

Dmitry E. Oboukhov opdagede at skriptet qemu-make-debian-root i qemu, en hurtig processor-emulator, oprettede midlertidige filer på usikker vis, hvilket måske kunne føre til et lokal lammelsesangreb (denial af service) gennem symlinks.

I den stabile distribution (etch), er dette problem rettet i version 0.8.2-4etch2.

I distributionen testing (lenny) og i den ustabile distribution (sid), er dette problem rettet i version 0.9.1-6.

Vi anbefaler at du opgraderer din qemu-pakke.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch2.dsc
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2.orig.tar.gz
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch2.diff.gz
AMD64:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch2_amd64.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch2_i386.deb
PowerPC:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch2_powerpc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.