Debians sikkerhedsbulletin

DSA-1674-1 jailer -- usikker generering af midlertidig fil

Rapporteret den:
30. nov 2008
Berørte pakker:
jailer
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 410548.
I Mitres CVE-ordbog: CVE-2008-5139.
Yderligere oplysninger:

Javier Fernandez-Sanguino Pena opdagede at updatejail, en komponent hørende til chroot-vedligeholdelsesværktøjet Jailer, oprettede et forudsigeligt midlertidigt filnavn, hvilket måske kunne føre til lammelsesangreb (denial of service) gennem et symlink-angreb.

I den stabile distribution (etch), er dette problem rettet i version 0.4-9+etch1.

I den kommande stabile distribution (lenny) og i den unstabile distribution (sid), er dette problem rettet i version 0.4-10.

Vi anbefaler at du opgraderer din jailer-pakke.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/j/jailer/jailer_0.4-9+etch1.diff.gz
http://security.debian.org/pool/updates/main/j/jailer/jailer_0.4.orig.tar.gz
http://security.debian.org/pool/updates/main/j/jailer/jailer_0.4-9+etch1.dsc
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/j/jailer/jailer_0.4-9+etch1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.