Debians sikkerhedsbulletin

DSA-1714-1 rt2570 -- heltalsoverløb

Rapporteret den:
28. jan 2009
Berørte pakker:
rt2570
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2009-0282.
Yderligere oplysninger:

Man opdagede at et heltalsoverløb i Probe Request-pakkefortolkeren i trådløsdriverne til Ralinktech måske kunne føre til fjernudført lammelsesangreb (denial of service) eller udførelse af vilkårlig kode.

Bemærk at du skal genopbygge din driver ud fra kildekodepakken, for at denne opdatering kan træde i kraft. Udførlig vejledning findes i /usr/share/doc/rt2570-source/README.Debian

I den stabile distribution (etch), er dette problem rettet i version 1.1.0+cvs20060620-3+etch1.

I den kommende stabile distribution (lenny) og i den ustabile distribution (sid), er dette problem rettet i version 1.1.0+cvs20080623-2.

Vi anbefaler at du opgraderer din rt2570-pakke.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620-3+etch1.dsc
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620-3+etch1.diff.gz
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/r/rt2570/rt2570-source_1.1.0+cvs20060620-3+etch1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.