Debian セキュリティ勧告

DSA-1714-1 rt2570 -- 整数オーバフロー

報告日時:
2009-01-28
影響を受けるパッケージ:
rt2570
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2009-0282.
詳細:

Ralinktech 社の無線 LAN チップドライバんの "Probe Request" パーザに整数 オーバフローがあり、リモートからサービス拒否攻撃や任意のコードの実行が可 能であることが発見されました。

この更新の効果を出すには、ドライバのリビルドが必要なことに留意ください。 詳細な手順は、以下のファイルをご覧ください。 /usr/share/doc/rt2570-source/README.Debian

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 1.1.0+cvs20060620-3+etch1 で修正されています。

次期安定版 (lenny) および不安定版 (unstable) ディストリビューション (sid) では、これらの問題はバージョン 1.1.0+cvs20080623-2 で修正されています。

直ぐに rt2570 パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620-3+etch1.dsc
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620-3+etch1.diff.gz
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/r/rt2570/rt2570-source_1.1.0+cvs20060620-3+etch1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。