Debian Security Advisory

DSA-1716-1 vnc4 -- integer overflow

Date Reported:
31 Jan 2009
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 513531.
In Mitre's CVE dictionary: CVE-2008-4770.
More information:

It was discovered that xvnc4viewer, a virtual network computing client software for X, is prone to an integer overflow via a malicious encoding value that could lead to arbitrary code execution.

For the stable distribution (etch) this problem has been fixed in version 4.1.1+X4.3.0-21+etch1.

For the unstable (sid) distribution this problem has been fixed in version 4.1.1+X4.3.0-31.

For the testing (lenny) distribution this problem will be fixed soon.

We recommend that you upgrade your vnc4 packages.

Fixed in:

Debian GNU/Linux 4.0 (etch)

HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.